NinjaTrader 7 Connection Instructions

If you already have NinjaTrader on your computer you can use your current installation. If you have your own NinjaTrader license key please download R|Trader and skip to Step 4.

Watch this video for a walkthrough of the connection instructions.

  1. Download NinjaTrader 7

    If a "Get Connected" window pops up, click the "skip" button located on the bottom left side of the pop-up.

  2. Be sure to download version 14.17 or higher of R|Trader and follow these instructions to connect.
  3. NinjaTrader control center:

    • Click Help
    • Click License Key
    • Erase the current License Key and replace it with @TST-COMB-INE1-RITH-MICF-REE2-LIVE-SIM3
    • Click Okmceclip3.png
    • When prompted "Do you want NinjaTrader to be in simulation mode on application startup?", select 'No'

      mceclip5.png

  4. From the NinjaTrader control center:

    • Click on the Tools menu, then select Account Connections
    • Click Add

      mceclip6.png

        • The Connection Options menu will pop up:
        • Click Next
        • Connection Name: Topstep
        • Provider: Rithmic for NinjaTrader Brokerage
        • To Connect on Startup, click the box to enable
        • Historical Data, select: Enabled

          mceclip1.png

        • Click Next
        • Username, type: (found in Account Information email)
        • Password, type: (found in Account Information email)
        • System: TopstepTrader Paper Trading
          • If you do not see TopstepTrader Paper Trading you will need to upgrade the version of NinjaTrader you are using by clicking the link in Step 1mceclip2.png
        • Click Next
        • Click Finish
        • Close Account Connection Set Up window
        • From the NinjaTrader Control Center, click on the File menu, hover over Connect and click Topstep
        • You should now see a green box on the bottom left of your NinjaTrader Control Panel that says "Connected to Rithmic For NinjaTrader Brokerage"

If you are still having trouble logging in please click here

Important things to know before getting started:

  • ALWAYS monitor your NET P&L in R|Trader rather than NinjaTrader by clicking on Trader Dashboard, and locating the column labeled P&L. R|Trader automatically calculates commissions and fees, while NinjaTrader does not display your Net P&L accurately in real-time. Topstep® Trade Reports are calculated using the data from R|Trader.
  • Trades placed in SIM101 will not be sent to us. Please be sure to trade in the correct account (found in the Account Information email).

 

Was this article helpful?
38 out of 41 found this helpful